using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}[A-Z]-[A-Z]+$";
string input = @"PASS :
16B-SCHUIF
32B-MATH
08B-SCHUIF
FAIL :
8B-SCHUIF
16B-42SCHUIF
16BSCHUIF
16-SCHUIF
16B-SCHUIF42A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}