const regex = /^\d{2}[A-Z]-[A-Z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{2}[A-Z]-[A-Z]+$', 'gm')
const str = `PASS :
16B-SCHUIF
32B-MATH
08B-SCHUIF
FAIL :
8B-SCHUIF
16B-42SCHUIF
16BSCHUIF
16-SCHUIF
16B-SCHUIF42A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}