package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}[A-Z]-[A-Z]+$`)
var str = `PASS :
16B-SCHUIF
32B-MATH
08B-SCHUIF
FAIL :
8B-SCHUIF
16B-42SCHUIF
16BSCHUIF
16-SCHUIF
16B-SCHUIF42A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}