re = /^\d{2}[A-Z]-[A-Z]+$/m
str = 'PASS :
16B-SCHUIF
32B-MATH
08B-SCHUIF
FAIL :
8B-SCHUIF
16B-42SCHUIF
16BSCHUIF
16-SCHUIF
16B-SCHUIF42A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end