import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Lib\\.myfunction\\s*\\(\\s*\\S+(?:,\\s*\\S+)*\\s*\\)";
final String string = "Lib.myfunction( arg0, arg1,\n"
+ " arg2, arg3 )\n"
+ "other text.\n"
+ "Lib.myfunction ( arg0, arg1, arg2, arg3 )\n\n"
+ "Lib.myfunction ( arg0, \n"
+ " arg1,\n"
+ " arg2,\n"
+ " arg3\n"
+ " )\n"
+ "blah.blah ( arg0, arg1,\n"
+ " arg2, arg3 )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}