const regex = /Lib\.myfunction\s*\(\s*\S+(?:,\s*\S+)*\s*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Lib\\.myfunction\\s*\\(\\s*\\S+(?:,\\s*\\S+)*\\s*\\)', 'gm')
const str = `Lib.myfunction( arg0, arg1,
arg2, arg3 )
other text.
Lib.myfunction ( arg0, arg1, arg2, arg3 )
Lib.myfunction ( arg0,
arg1,
arg2,
arg3
)
blah.blah ( arg0, arg1,
arg2, arg3 )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}