// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Lib\.myfunction\s*\(\s*\S+(?:,\s*\S+)*\s*\)").unwrap();
let string = "Lib.myfunction( arg0, arg1,
arg2, arg3 )
other text.
Lib.myfunction ( arg0, arg1, arg2, arg3 )
Lib.myfunction ( arg0,
arg1,
arg2,
arg3
)
blah.blah ( arg0, arg1,
arg2, arg3 )";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}