import Foundation
let pattern = #"Lib\.myfunction\s*\(\s*\S+(?:,\s*\S+)*\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lib.myfunction( arg0, arg1,
arg2, arg3 )
other text.
Lib.myfunction ( arg0, arg1, arg2, arg3 )
Lib.myfunction ( arg0,
arg1,
arg2,
arg3
)
blah.blah ( arg0, arg1,
arg2, arg3 )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)