use strict;
my $str = 'Lib.myfunction( arg0, arg1,
arg2, arg3 )
other text.
Lib.myfunction ( arg0, arg1, arg2, arg3 )
Lib.myfunction ( arg0,
arg1,
arg2,
arg3
)
blah.blah ( arg0, arg1,
arg2, arg3 )';
my $regex = qr/Lib\.myfunction\s*\(\s*\S+(?:,\s*\S+)*\s*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}