# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bget_description\((.*?)\)/$1/gm;t' <<< "some text here get_description('string_value') more text..."