const regex = /\bget_description\((.*?)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bget_description\\((.*?)\\)', 'gm')
const str = `some text here get_description('string_value') more text...`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);