use strict;
my $str = 'some text here get_description(\'string_value\') more text...';
my $regex = qr/\bget_description\((.*?)\)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";