#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*@[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*$"
Local $sString = "firstname.lastname@domain.com" & @CRLF & _
"firstname.lastname@domain.co.uk" & @CRLF & _
"firstname.lastname@domain.de" & @CRLF & _
"firstname-secondname.lastname@domainPart1-domainPart2.de" & @CRLF & _
"" & @CRLF & _
"_firstname.lastname@domain.com" & @CRLF & _
"firstname..lastname@domain.co.uk" & @CRLF & _
"firstname lastname@domain.de" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")