import re
regex = re.compile(r"^[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*@[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*$", flags=re.MULTILINE)
test_str = ("firstname.lastname@domain.com\n"
"firstname.lastname@domain.co.uk\n"
"firstname.lastname@domain.de\n"
"firstname-secondname.lastname@domainPart1-domainPart2.de\n\n"
"_firstname.lastname@domain.com\n"
"firstname..lastname@domain.co.uk\n"
"firstname lastname@domain.de\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")