import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*@[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*$";
final String string = "firstname.lastname@domain.com\n"
+ "firstname.lastname@domain.co.uk\n"
+ "firstname.lastname@domain.de\n"
+ "firstname-secondname.lastname@domainPart1-domainPart2.de\n\n"
+ "_firstname.lastname@domain.com\n"
+ "firstname..lastname@domain.co.uk\n"
+ "firstname lastname@domain.de\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}