re = /^[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*@[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*$/m
str = 'firstname.lastname@domain.com
firstname.lastname@domain.co.uk
firstname.lastname@domain.de
firstname-secondname.lastname@domainPart1-domainPart2.de
_firstname.lastname@domain.com
firstname..lastname@domain.co.uk
firstname lastname@domain.de
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end