package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*@[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*$`)
var str = `firstname.lastname@domain.com
firstname.lastname@domain.co.uk
firstname.lastname@domain.de
firstname-secondname.lastname@domainPart1-domainPart2.de
_firstname.lastname@domain.com
firstname..lastname@domain.co.uk
firstname lastname@domain.de
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}