$re = '/^[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*@[A-Za-z0-9]+(?:[_.-][A-Za-z0-9]+)*$/m';
$str = 'firstname.lastname@domain.com
firstname.lastname@domain.co.uk
firstname.lastname@domain.de
firstname-secondname.lastname@domainPart1-domainPart2.de
_firstname.lastname@domain.com
firstname..lastname@domain.co.uk
firstname lastname@domain.de
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);