#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?=a+((?(1)\1)b))a)*\1)?$"
Local $sString = "Yes:" & @CRLF & _
"" & @CRLF & _
"ab" & @CRLF & _
"aabb" & @CRLF & _
"aaabbb" & @CRLF & _
"aaaabbbb" & @CRLF & _
"aaaaabbbbb" & @CRLF & _
"" & @CRLF & _
"No:" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"aaa" & @CRLF & _
"aab" & @CRLF & _
"abb" & @CRLF & _
"bbb" & @CRLF & _
"aaaa" & @CRLF & _
"aaab" & @CRLF & _
"abbb" & @CRLF & _
"bbbb" & @CRLF & _
"aaaaa" & @CRLF & _
"aaaab" & @CRLF & _
"aaabb" & @CRLF & _
"aabbb" & @CRLF & _
"abbbb" & @CRLF & _
"bbbbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")