import re
regex = re.compile(r"^(?:(?:(?=a+((?(1)\1)b))a)*\1)?$", flags=re.MULTILINE)
test_str = ("Yes:\n\n"
"ab\n"
"aabb\n"
"aaabbb\n"
"aaaabbbb\n"
"aaaaabbbbb\n\n"
"No:\n"
"a\n"
"b\n"
"aaa\n"
"aab\n"
"abb\n"
"bbb\n"
"aaaa\n"
"aaab\n"
"abbb\n"
"bbbb\n"
"aaaaa\n"
"aaaab\n"
"aaabb\n"
"aabbb\n"
"abbbb\n"
"bbbbb")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")