const regex = new RegExp('^(?:(?:(?=a+((?(1)\\1)b))a)*\\1)?$', 'gm')
const str = `Yes:
ab
aabb
aaabbb
aaaabbbb
aaaaabbbbb
No:
a
b
aaa
aab
abb
bbb
aaaa
aaab
abbb
bbbb
aaaaa
aaaab
aaabb
aabbb
abbbb
bbbbb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}