re = /^(?:(?:(?=a+((?(1)\1)b))a)*\1)?$/m
str = 'Yes:
ab
aabb
aaabbb
aaaabbbb
aaaaabbbbb
No:
a
b
aaa
aab
abb
bbb
aaaa
aaab
abbb
bbbb
aaaaa
aaaab
aaabb
aabbb
abbbb
bbbbb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end