using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?=a+((?(1)\1)b))a)*\1)?$";
string input = @"Yes:
ab
aabb
aaabbb
aaaabbbb
aaaaabbbbb
No:
a
b
aaa
aab
abb
bbb
aaaa
aaab
abbb
bbbb
aaaaa
aaaab
aaabb
aabbb
abbbb
bbbbb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}