using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:^https?\:\/\/)?(?:www\.)?[a-z0-9-]+\.[a-z]+(?:[?\/].*)?$";
string input = @"https://yandex.ru
https://www.google.com
http://localhost.my
www.awesome.site
www.example1.com
www.example1.comwww.example2.com
www.example1.com?q=s
www.example1.com/qwerty
www.some-stuff.domain
WWW.SOME-STUFF1.COM
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}