const regex = /^(?:^https?\:\/\/)?(?:www\.)?[a-z0-9-]+\.[a-z]+(?:[?\/].*)?$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:^https?\\:\\\/\\\/)?(?:www\\.)?[a-z0-9-]+\\.[a-z]+(?:[?\\\/].*)?$', 'mgi')
const str = `https://yandex.ru
https://www.google.com
http://localhost.my
www.awesome.site
www.example1.com
www.example1.comwww.example2.com
www.example1.com?q=s
www.example1.com/qwerty
www.some-stuff.domain
WWW.SOME-STUFF1.COM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}