import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:^https?\\:\\/\\/)?(?:www\\.)?[a-z0-9-]+\\.[a-z]+(?:[?\\/].*)?$";
final String string = "https://yandex.ru\n"
+ "https://www.google.com\n"
+ "http://localhost.my\n"
+ "www.awesome.site\n"
+ "www.example1.com\n"
+ "www.example1.comwww.example2.com\n"
+ "www.example1.com?q=s\n"
+ "www.example1.com/qwerty\n"
+ "www.some-stuff.domain\n"
+ "WWW.SOME-STUFF1.COM\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}