re = /^(?:^https?\:\/\/)?(?:www\.)?[a-z0-9-]+\.[a-z]+(?:[?\/].*)?$/mi
str = 'https://yandex.ru
https://www.google.com
http://localhost.my
www.awesome.site
www.example1.com
www.example1.comwww.example2.com
www.example1.com?q=s
www.example1.com/qwerty
www.some-stuff.domain
WWW.SOME-STUFF1.COM
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end