$re = '/^(?:^https?\:\/\/)?(?:www\.)?[a-z0-9-]+\.[a-z]+(?:[?\/].*)?$/mi';
$str = 'https://yandex.ru
https://www.google.com
http://localhost.my
www.awesome.site
www.example1.com
www.example1.comwww.example2.com
www.example1.com?q=s
www.example1.com/qwerty
www.some-stuff.domain
WWW.SOME-STUFF1.COM
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);