// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:^https?\:\/\/)?(?:www\.)?[a-z0-9-]+\.[a-z]+(?:[?\/].*)?$").unwrap();
let string = "https://yandex.ru
https://www.google.com
http://localhost.my
www.awesome.site
www.example1.com
www.example1.comwww.example2.com
www.example1.com?q=s
www.example1.com/qwerty
www.some-stuff.domain
WWW.SOME-STUFF1.COM
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}