# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Logger.([a-z]+)\(([^)]+)\);/Logger.$1($2 + " [" + Thread.currentThread().getStackTrace()[1].getLineNumber() + "]");/gm;t' <<< "Logger.info(className, dasd + \"sadsd\" );"