$re = '/Logger.([a-z]+)\(([^)]+)\);/m';
$str = 'Logger.info(className, dasd + "sadsd" );';
$subst = "Logger.$1($2 + \" [\" + Thread.currentThread().getStackTrace()[1].getLineNumber() + \"]\");";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;