use strict;
my $str = 'Logger.info(className, dasd + "sadsd" );';
my $regex = qr/Logger.([a-z]+)\(([^)]+)\);/mp;
my $subst = 'Logger.$1($2 + " [" + Thread.currentThread().getStackTrace()[1].getLineNumber() + "]");';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";