#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Logger.([a-z]+)\(([^)]+)\);"
Local $sString = "Logger.info(className, dasd + "sadsd" );"
Local $sSubst = "Logger.$1($2 + " [" + Thread.currentThread().getStackTrace()[1].getLineNumber() + "]");"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)