// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Logger.([a-z]+)\(([^)]+)\);").unwrap();
let string = "Logger.info(className, dasd + \"sadsd\" );";
let substitution = "Logger.$1($2 + \" [\" + Thread.currentThread().getStackTrace()[1].getLineNumber() + \"]\");";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}