const regex = /Logger.([a-z]+)\(([^)]+)\);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Logger.([a-z]+)\\(([^)]+)\\);', 'gm')
const str = `Logger.info(className, dasd + "sadsd" );`;
const subst = `Logger.$1($2 + " [" + Thread.currentThread().getStackTrace()[1].getLineNumber() + "]");`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);