#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9a-f]{32})"
Local $sString = "какой-то текст" & @CRLF & _
"var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';" & @CRLF & _
"какой-то текст" & @CRLF & _
"какой-то текст" & @CRLF & _
"var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';" & @CRLF & _
"какой-то текст" & @CRLF & _
"какой-то текст" & @CRLF & _
"var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';" & @CRLF & _
"какой-то текст" & @CRLF & _
"какой-то текст" & @CRLF & _
"var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';" & @CRLF & _
"какой-то текст" & @CRLF & _
"какой-то текст" & @CRLF & _
"var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';" & @CRLF & _
"какой-то текст"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")