re = /([0-9a-f]{32})/
str = 'какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-т о текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end