$re = '/([0-9a-f]{32})/';
$str = 'какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);