// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9a-f]{32})").unwrap();
let string = "какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}