use strict;
my $str = 'какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст
какой-то текст
var md5_api_key = \'e18610f6e6777924cb3543bc3dbb23fc\';
какой-то текст';
my $regex = qr/([0-9a-f]{32})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}