const regex = /([0-9a-f]{32})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9a-f]{32})', 'g')
const str = `какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст
какой-то текст
var md5_api_key = 'e18610f6e6777924cb3543bc3dbb23fc';
какой-то текст`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}