#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<=voyageCode=)[^=&\s]+)|((?<=portid=)[^=&\s]+)"
Local $sString = "/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=SYD" & @CRLF & _
"/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=BNE" & @CRLF & _
"/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=JFM" & @CRLF & _
"/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=SYD" & @CRLF & _
"/excursion/popupPortPOI.do?voyageCode=S517&tourCode=&travelOrder=A&portid=BNE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")