import Foundation
let pattern = #"((?<=voyageCode=)[^=&\s]+)|((?<=portid=)[^=&\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=SYD
/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=BNE
/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=JFM
/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=SYD
/excursion/popupPortPOI.do?voyageCode=S517&tourCode=&travelOrder=A&portid=BNE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)