import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=voyageCode=)[^=&\\s]+)|((?<=portid=)[^=&\\s]+)";
final String string = "/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=SYD\n"
+ "/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=BNE\n"
+ "/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=JFM\n"
+ "/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=SYD\n"
+ "/excursion/popupPortPOI.do?voyageCode=S517&tourCode=&travelOrder=A&portid=BNE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}