import re
regex = re.compile(r"((?<=voyageCode=)[^=&\s]+)|((?<=portid=)[^=&\s]+)")
test_str = ("/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=SYD\n"
"/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=BNE\n"
"/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=JFM\n"
"/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=SYD\n"
"/excursion/popupPortPOI.do?voyageCode=S517&tourCode=&travelOrder=A&portid=BNE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")