using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=voyageCode=)[^=&\s]+)|((?<=portid=)[^=&\s]+)";
string input = @"/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=SYD
/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=BNE
/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=JFM
/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=SYD
/excursion/popupPortPOI.do?voyageCode=S517&tourCode=&travelOrder=A&portid=BNE";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}