$re = '/((?<=voyageCode=)[^=&\s]+)|((?<=portid=)[^=&\s]+)/';
$str = '/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=SYD
/excursion/popupPortPOI.do?voyageCode=S515&tourCode=&travelOrder=A&portid=BNE
/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=JFM
/excursion/popupPortPOI.do?voyageCode=D520&tourCode=&travelOrder=A&portid=SYD
/excursion/popupPortPOI.do?voyageCode=S517&tourCode=&travelOrder=A&portid=BNE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);