using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|-+\|-+\|\s*(.*?)(?=\s*\|-+\|-+\|)";
string input = @"Donec sed odio dui. Donec id elit non mi porta gravida at eget metus.
|------|------|
|6 | TEXT |
|7 | TEXT |
|8,9 | TEXT |
|------|------|
Etiam porta sem malesuada magna mollis euismod. Praesent commodo cursus magna,
vel scelerisque nisl consectetur et. Nulla vitae elit libero, a pharetra ";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}