import re
regex = re.compile(r"\|-+\|-+\|\s*(.*?)(?=\s*\|-+\|-+\|)", flags=re.DOTALL)
test_str = ("Donec sed odio dui. Donec id elit non mi porta gravida at eget metus.\n"
"|------|------| \n"
"|6 | TEXT | \n"
"|7 | TEXT | \n"
"|8,9 | TEXT | \n"
"|------|------|\n"
"Etiam porta sem malesuada magna mollis euismod. Praesent commodo cursus magna,\n"
"vel scelerisque nisl consectetur et. Nulla vitae elit libero, a pharetra ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")