re = /\|-+\|-+\|\s*(.*?)(?=\s*\|-+\|-+\|)/
str = 'Donec sed odio dui. Donec id elit non mi porta gravida at eget metus.
|------|------|
|6 | TEXT |
|7 | TEXT |
|8,9 | TEXT |
|------|------|
Etiam porta sem malesuada magna mollis euismod. Praesent commodo cursus magna,
vel scelerisque nisl consectetur et. Nulla vitae elit libero, a pharetra '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end